Raspberry Pi - MFBot Konsolenversion

Benutzeravatar
TakeViagraDieHard
Spender
Beiträge: 133
Registriert: Fr 29. Jun 2018, 21:53
Wohnort: NRW
Hat sich bedankt: 13 Mal
Danksagung erhalten: 43 Mal

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von TakeViagraDieHard »

Ich habe gerade das Update auf die 5.2.0.3 gemacht und es läuft bei mir. Welche Mono Verison hast du denn installiert?
Bei mir ist die 6.4.0.198 drauf.
Benutzeravatar
seboka
Beiträge: 240
Registriert: Mo 4. Jan 2016, 15:24
Hat sich bedankt: 6 Mal
Danksagung erhalten: 12 Mal

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von seboka »

Lohnt sich der Raspberry 4 und gibt es eine gute Alternative für EXagear (Betrieb wurde eingestellt)?
Jack Sparrow
Beiträge: 2
Registriert: Mi 12. Feb 2020, 16:24
Hat sich bedankt: 0
Danksagung erhalten: 0

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Jack Sparrow »

Bei mir kommt diese Fehlermeldung: Ist das noch aktuell, dass der Bot auf dem Rasp mit aktueller Version laufen soll? Bin leider etwas planlos was das hier bedeutet.... bin für jede Hilfe dankbar...

Edit: Ich hab jetzt nochmal von vorn angefangen und habe jetzt etwas weniger Fehlercode bekommen ;) :D

./MFBot_Konsole_ARMRasp: Zeile 1: Syntaxfehler beim unerwarteten Wort `newline'
./MFBot_Konsole_ARMRasp: Zeile 1: `<!DOCTYPE html>'
Jack_Rookie
Beiträge: 11
Registriert: Do 12. Jan 2017, 16:32
Hat sich bedankt: 3 Mal
Danksagung erhalten: 1 Mal

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Jack_Rookie »

Hey, wo hast du 'newline' verwendet? Wie gehst Du vor bzw. was hast Du bis jetzt gemacht?
Ich nutze einen Pi der ersten Generation, welcher zum Ausführen des Bots völlig ausreichend ist. Alles Andere währe mit Kanonen auf Spatzen zu schießen. :-)

Da der Pi nur für den Bot da ist, liegen die benötigten Dateien einfach im Hauptpfad.
JR
Enno1337
Beiträge: 10
Registriert: Fr 6. Dez 2019, 15:51
Hat sich bedankt: 0
Danksagung erhalten: 0

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Enno1337 »

moin
seid den update ( habe den PI komplett neu aufgesetzt weil das updaten nicht geklappt hat)
loggt der bot sich zwar ein.. macht auch ganz selten mal ne quest und sonst irgendwie nix

eingestellt scheint alles richtig zu sein

kann mir da mal wer helfen und kennt das problem? bei check is der bot immer online.. loggt sich ein und wenn ich mitm handy reingehe schmeisst der mich fast net mehr raus

das war vorher anders

mfg
Betzabua
Beiträge: 4
Registriert: Do 20. Jun 2019, 19:56
Hat sich bedankt: 0
Danksagung erhalten: 1 Mal

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Betzabua »

Hallo Zusammen,


ich habe seit neuestem einen Pi 4 und wollte darauf den Bot laufen lassen...

soweit so gut, habe Raspian installiert, Mono-Runtime installiert...

alles hat geklappt bis zum Punkt wo ich cd SF eingeben soll...
Da kommt bei mir jedes mal:

bash: cd: SF: Datei oder Verzeichnis nicht gefunden

also gut, dann schreibe ich eben cd SFBot


das findet er dann und ich fahre weiter fort mit chmod +x MFBot_Konsole_ARMRasp

und dann weiter mit ./MFBot_Konsole_ARMRasp


naja und dann kommt folgender Fehler:

Fehler
Unhandled Exception:
System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoDriver..ctor (System.String term) [0x00055] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver..cctor () [0x0004d] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.Console..cctor () [0x0008e] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at BasisFightSimulation.FightSimulationAssemblyLoader.Load () [0x00000] in <2e9f1973d824441fa3695eec9537c772>:0
at de.mfbot.MFBot_NG.Konsole.Program.Main (System.String[] args) [0x00000] in <0f65a4e71ebc46c39e773b2138561048>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.TermInfoDriver..ctor (System.String term) [0x00055] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.ConsoleDriver..cctor () [0x0004d] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <a6f810169ec746eeb2789b925e2858c0>:0
at System.Console..cctor () [0x0008e] in <a6f810169ec746eeb2789b925e2858c0>:0
--- End of inner exception stack trace ---
at BasisFightSimulation.FightSimulationAssemblyLoader.Load () [0x00000] in <2e9f1973d824441fa3695eec9537c772>:0
at de.mfbot.MFBot_NG.Konsole.Program.Main (System.String[] args) [0x00000] in <0f65a4e71ebc46c39e773b2138561048>:0
kann mir da jemand helfen wo das Problem liegt?

die Acc.Ini datei liegt in besagtem SFBot Ordner...
Benutzeravatar
Robin
Administrator
Beiträge: 1596
Registriert: So 30. Jun 2013, 18:12
Wohnort: Rheinland-Pfalz
Hat sich bedankt: 261 Mal
Danksagung erhalten: 241 Mal

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Robin »

Hi Betzabua,
siehe dazu hier: viewtopic.php?f=20&t=1391&start=80#p13523

Der Fehler sollte laut dem dazugehörigen Issue mit Mono 5.12 gelöst worden sein, wenn er das nicht ist, ist entweder deine Mono-Version zu alt (ausgehend von Debian Buster / dem neuesten Raspbian dürfte das nicht der Fall sein) oder das Problem ist eventuell doch ein anderes.
So oder so sollte der verlinkte Workaround funktionieren.

Grüße
Robin
MFBot-VersionCode-Zeilen*In Dateien*Letzte Version
MFBot 1.5.x64851Juli 2013
MFBot 2.x1436316März 2014
MFBot 3.x2209536März 2015
MFBot 4.x55242241Juli 2018
MFBot 5.x66000440Tbc
*Ohne automatisch generierten Designer-Code
Meruem
Beiträge: 8
Registriert: Mo 11. Mär 2019, 20:34
Hat sich bedankt: 1 Mal
Danksagung erhalten: 0

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Meruem »

Jack Sparrow hat geschrieben: Mi 12. Feb 2020, 16:27 Bei mir kommt diese Fehlermeldung: Ist das noch aktuell, dass der Bot auf dem Rasp mit aktueller Version laufen soll? Bin leider etwas planlos was das hier bedeutet.... bin für jede Hilfe dankbar...

Edit: Ich hab jetzt nochmal von vorn angefangen und habe jetzt etwas weniger Fehlercode bekommen ;) :D

./MFBot_Konsole_ARMRasp: Zeile 1: Syntaxfehler beim unerwarteten Wort `newline'
./MFBot_Konsole_ARMRasp: Zeile 1: `<!DOCTYPE html>'
Moin,

habe mir heute auf meinem LinuxServer x64 die neue MFBotVersion heruntergeladen mithilfe von
wget http://www.mfbot.de/Download/latest/MF ... ole_x86_64

Mit chmod a+x hinzugefügt. Sobald ich mit ./ ausführen will erscheint der Syntaxfehler. Jemand eine Idee woran es liegt?
Benutzeravatar
Robin
Administrator
Beiträge: 1596
Registriert: So 30. Jun 2013, 18:12
Wohnort: Rheinland-Pfalz
Hat sich bedankt: 261 Mal
Danksagung erhalten: 241 Mal

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Robin »

Hi Meruem,
danke dir für die Meldung, zur Zeit scheint das System die Downloadlinks nicht automatisch richtig zu setzen.
Ich melde mich nochmal, wenn es wieder läuft, in der Zeit kannst du den Direktlink nutzen: https://mfbot.de/Download/v5.3.1.0/MFBot_Konsole_x86_64

Grüße
Robin
MFBot-VersionCode-Zeilen*In Dateien*Letzte Version
MFBot 1.5.x64851Juli 2013
MFBot 2.x1436316März 2014
MFBot 3.x2209536März 2015
MFBot 4.x55242241Juli 2018
MFBot 5.x66000440Tbc
*Ohne automatisch generierten Designer-Code
Meruem
Beiträge: 8
Registriert: Mo 11. Mär 2019, 20:34
Hat sich bedankt: 1 Mal
Danksagung erhalten: 0

Re: Raspberry Pi - MFBot Konsolenversion

Beitrag von Meruem »

Moin Robin

vielen Dank für die Rückmeldung. Jetzt läufst auch wieder.
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast